It was a bit tricky. 303 error on temp domain and a strange location of database config info. But all solved. One down in #HostGator.