@digitalocean Turns out the issue was that I didn't select an SSH key. It's a FreeBSD droplet. A more useful error would have been nice.